Team (6/9/21) - RESOLVED
Incident Report for Payscale
Resolved
This incident has been resolved.
Posted Jun 09, 2021 - 19:02 PDT
Update
Issues have been identified and resolved.
Posted Jun 09, 2021 - 19:02 PDT
Update
We are currently experiencing issues with the Team product. The PayScale Team has identified the root cause and is working to resolve. We will post an updated status at 8:00 pm EST or sooner if the issue is resolved.
Posted Jun 09, 2021 - 15:27 PDT
Identified
We are currently experiencing issues with the Team product. The PayScale Team has identified the root cause and is working to resolve. We will post an updated status at 6:30 pm EST or sooner if the issue is resolved.
Posted Jun 09, 2021 - 14:22 PDT
Investigating
We are currently experiencing issues with the Team product. The PayScale Team is investigating and will post an updated status as soon as information is available or no later than 5:15 pm EST. We apologize for any inconvenience.
Posted Jun 09, 2021 - 13:50 PDT
This incident affected: Team (Job Collaboration, Pay Cycle Execution).