Insight and Benchmark Intermittent Performance Issues

Incident Report for Payscale

Resolved

Engineering has determined the root cause and resolve the performance issues experienced by the PayScale Insight and Benchmark products.
Posted 4 years ago. Jul 21, 2021 - 08:09 PDT

Investigating

We are aware and investigating an issue impacting performance for the PayScale Insight and Benchmark products.
Posted 4 years ago. Jul 20, 2021 - 15:11 PDT
This incident affected: Insight (Market Reports, Market Differential Analysis, Job Matching, Analytics) and Benchmark (Market Reports, Market Differential Analysis, Job Matching, Analytics).