3.11.2019 – Insight & Benchmark Outage
Incident Report for Payscale
Resolved
This has been resolved as of 10:27 AM PT. Please email cs@payscale.com if you continue to experience any issues
Posted Mar 11, 2019 - 10:28 PDT
Investigating
We are investigating issues impacting report generation in Insight and Benchmark for all users. The PayScale Team is investigating and will post an updated status as soon as possible. We apologize for any inconvenience.
Posted Mar 11, 2019 - 09:31 PDT
This incident affected: Insight (Market Reports) and Benchmark (Market Reports).