Insight & Benchmark Outage

Incident Report for Payscale

Resolved

This incident has been resolved.
Posted Jul 30, 2020 - 06:48 PDT

Update

We are continuing to investigate this issue.
Posted Jul 29, 2020 - 08:34 PDT

Investigating

We are investigating an issue impacting access to the PayScale Insight and Benchmark products. Our Engineers are working promptly to resolve the issue as soon as possible.
Posted Jul 29, 2020 - 08:33 PDT
This incident affected: Insight (Market Reports, Market Differential Analysis, Job Matching, Analytics) and Benchmark (Market Reports, Market Differential Analysis, Job Matching, Analytics).