Automated Platform Emails Delivery

Incident Report for Payscale

Resolved

This incident has been resolved.
Posted Jan 09, 2026 - 12:00 PST

Update

Our Engineering is continuing to work on a fix for this issue.

Please submit a case to our support team (via support@payscale.com) for assistance and our team is happy to help.
Posted Jan 08, 2026 - 16:26 PST

Identified

Marketpay, Benchmark, and Insight, and payscale.com platforms are currently experiencing an issue impacting the delivery of some automated platform emails to users - including password reset and new user invitation emails.

Our engineering team is investigating and working to resolve with top priority.

If you believe you should have received an email from the Marketpay, Benchmark, Insight, or payscale.com platform and did not, please submit a case to our support team (via support@payscale.com) and our team is happy to assist you.
Posted Jan 08, 2026 - 10:05 PST
This incident affected: Insight (Market Reports, Market Differential Analysis, Job Matching, Analytics), Benchmark (Market Reports, Market Differential Analysis, Job Matching, Analytics), Payscale - www.payscale.com (Login/Password Reset), and Marketpay (MarketPay SSO).