Microsoft Azure outage impacting PayScale services
Incident Report for PayScale
Resolved
Engineering Teams have applied mitigation and services should be at full functionality.
Posted Feb 11, 2021 - 23:08 PST
Identified
We are currently experiencing issues with a variety of PayScale services due to a Microsoft Azure outage. We are actively in communication with Microsoft about the status of Azure and will continue to update as we hear further.
Posted Feb 11, 2021 - 18:42 PST