RESOLVED - 5.2.19 - Reported issues across multiple products
Incident Report for Payscale
Resolved
All services should be returning to normal as of 4:00 PM PDT. Please email cs@payscale.com if you continue to experience any issues related to site performance.
Posted May 02, 2019 - 16:03 PDT
Update
We are currently investigating broad issues across the Insight, Benchmark, Team and Lab products, due to an outside vendor outage. We will provide additional updates as they are available.
Posted May 02, 2019 - 14:14 PDT
Investigating
We are currently investigating broad issues across the Insight, Benchmark, Team and Lab products, due to an outside vendor outage. We will provide additional updates as they are available
Posted May 02, 2019 - 14:13 PDT
This incident affected: Insight (Market Reports, Market Differential Analysis, Job Matching, Analytics), Insight Lab (Market Reports, Job Matching, Analytics), Benchmark (Market Reports, Market Differential Analysis, Job Matching), and Team (Job Collaboration, Pay Cycle Execution).