Login Issues for Insight and Benchmark
Incident Report for Payscale
Resolved
This issue was resolved at 10:05 AM PST. We apologize for any inconvenience this may have caused.
Posted Feb 18, 2021 - 10:13 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 18, 2021 - 09:46 PST
Identified
We are aware and investigating an issue impacting login for the PayScale Insight and Benchmark products. We have identified the root cause of the issue and working to resolve as soon as possible.
Posted Feb 18, 2021 - 09:29 PST
This incident affected: Insight (Market Reports, Market Differential Analysis, Job Matching, Analytics) and Benchmark (Market Reports, Market Differential Analysis, Job Matching, Analytics).