Insight and Insight Lab - Crowdsourced Job Matching
Incident Report for Payscale
Resolved
We investigated issues impacting PayScale Crowdsource job matching in the Insight and Insight Lab products. These issues have now been resolved, and we apologize for any inconvenience this may have caused.
Posted Jan 30, 2019 - 09:50 PST
Investigating
We are investigating issues impacting PayScale Crowdsource job matching in the Insight and Insight Lab products. We apologize for any inconvenience this may cause.
Posted Jan 30, 2019 - 09:16 PST
This incident affected: Insight Lab (Job Matching) and Insight (Job Matching).