Insight Lab Outage
Incident Report for Payscale
Resolved
We were investigating issues impacting logging into Insight Lab. These issues have been resolved. We apologize for any inconvenience this may have caused!
Posted Feb 07, 2019 - 09:14 PST
Investigating
We are currently experiencing issues with the Lab product. The PayScale Team is investigating and will post an updated status as soon as possible. We apologize for any inconvenience!
Posted Feb 07, 2019 - 08:15 PST
This incident affected: Insight Lab (Market Reports, Job Matching, Analytics).