Access Issues
Incident Report for Payscale
Resolved
This incident has been resolved.
Posted Oct 05, 2020 - 12:42 PDT
Investigating
Some users are experiencing issues logging in to PayScale Insight Lab and Team. Our Development Team is actively working to resolve the issues as soon as possible.
Posted Oct 05, 2020 - 12:07 PDT
This incident affected: Insight Lab (Market Reports, Job Matching, Analytics) and Team (Job Collaboration, Pay Cycle Execution).