Degraded Peformance of Job Matching in Insight Lab

Incident Report for Payscale

Resolved

This incident has been resolved.
Posted Sep 06, 2019 - 12:08 PDT

Investigating

We are currently investigating this issue.
Posted Sep 06, 2019 - 10:48 PDT
This incident affected: Insight Lab (Job Matching).