Insight Lab (5/5/21) - RESOLVED
Incident Report for Payscale
Resolved
Insight Lab (5/5/21) - Resolved

We were investigating access issues impacting the Insight Lab product. The issue has been discovered and was resolved at 1:42 PM (EST). We apologize for any inconvenience this may have caused.
Posted May 05, 2021 - 10:42 PDT
Investigating
We are currently experiencing access issues with the Insight Lab product. The PayScale Team is investigating and will post an updated status as soon as information is available or no later than 02:15 pm eastern time. We apologize for any inconvenience.
Posted May 05, 2021 - 10:20 PDT
This incident affected: Insight Lab (Market Reports, Job Matching, Analytics).