Team Degraded Performance
Incident Report for PayScale
Resolved
Our developers have solved the issues impacting Team and performance should no longer be impacted.
Posted Feb 06, 2020 - 20:12 PST
Identified
Our development team has identified a fix and are working on a resolution. We do not have a firm ETA yet but work is in progress.
Posted Feb 06, 2020 - 10:54 PST
Update
Our development team has been working through the night and are still working to resolve the performance issues we have been seeing.
Posted Feb 06, 2020 - 08:41 PST
Investigating
We are currently experiencing issues with the Team. The PayScale Team is investigating and will post an updated status as soon as possible. We apologize for any inconvenience.
Posted Feb 05, 2020 - 14:57 PST
This incident affected: Team (Pay Cycle Execution).