Job Collab Currently Taken Down for Maintenance

Incident Report for Payscale

Resolved

Job Collab is now back up and fully functional.
Posted Aug 12, 2020 - 08:23 PDT

Investigating

Our development team has identified an issue with our Job Collab module that necessitates taking it down for several days. This page will be updated as soon as we have it back up for use again.
Posted Jul 15, 2020 - 16:47 PDT
This incident affected: Team (Job Collaboration).